Phone lines are down
Incident Report for Zambion
Resolved
This incident has been resolved.
Posted Jan 29, 2024 - 11:45 NZDT
Investigating
Our support phone lines are currently down. We've escalated this to our service provider and we hope to have an update shortly. In the meantime, if you need any assistance, please send an email through to service@zambion.com.
Posted Jan 29, 2024 - 11:22 NZDT
This incident affected: Cloud.