Issue with Timeclocks connecting to our servers
Incident Report for Zambion
Resolved
This incident has been resolved.
Posted Dec 13, 2021 - 09:04 NZDT
Investigating
We are currently investigating this issue.
Posted Dec 13, 2021 - 08:44 NZDT
This incident affected: Timeclocks.